PowerOutage.us is not updating
Incident Report for PowerOutage.us
Resolved
We have not seen any further issues from the AWS outage, and are marking this issue resolved.
Posted Nov 25, 2020 - 23:57 UTC
Update
We are starting to see full recovery, and are unfreezing utilities as their Outage management systems become accessible. We will continue to monitor the situation.
Posted Nov 25, 2020 - 19:07 UTC
Monitoring
We have manually segregated and frozen the utilities affected by the AWS outage, and are now updating outage data for the non affected utilities.
Posted Nov 25, 2020 - 18:49 UTC
Investigating
There appears to be an ongoing issue with AWS (a cloud service provider). While our site and system are still online and operational many utilities use AWS for their outage management systems. Due to the sheer number of OMSs offline our data collection process has stopped. (A safeguard to prevent bad data from being displayed on PowerOutage.us data during significant WWW issues)

Keep an eye year for the status of AWS: https://status.aws.amazon.com/
Posted Nov 25, 2020 - 17:42 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).