Azure Central Region Connectivity Issues
Incident Report for PowerOutage.us
Resolved
Azure has fully recovered US Central; no other issues have been found on our end.
If anyone runs into anything reach out to us at support@bluefirestudios.com

We will be making improvements to our redundancy, we were multi-zone redundant before this incident but will be expanding to multi-region redundancy, we now have a backup stack available in Azure US West and will be fleshing that out and testing failover in the coming weeks.
Posted Jul 19, 2024 - 11:10 UTC
Monitoring
Azure Central Region Connectivity Issues
https://azure.status.microsoft/en-us/status

Our primary database is back up and data is updating system wide.
We are monitoring the situation and double checking that everything is working.

The incident is still ongoing on Azure's end.
Posted Jul 19, 2024 - 02:34 UTC
Update
Azure Central Region Connectivity Issues
https://azure.status.microsoft/en-us/status

Primary database for PowerOutage.us is inaccessible.
Any returned web and API results are cached but stale.

We are working on standing up new infrastructure in US West
Posted Jul 18, 2024 - 22:30 UTC
Identified
Azure Central Region Connectivity Issues
https://azure.status.microsoft/en-us/status

We are looking into issues with Azure which are causing very high load times and errors. Check the Azure status page for more details.
Posted Jul 18, 2024 - 22:00 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).