Power Outage Systems not updating
Incident Report for PowerOutage.us
Resolved
Utility data is now updating site wide.
Posted Feb 28, 2022 - 18:10 UTC
Identified
A specific Ukrainian utility data integration is causing a critical data issue, The data issue is being caught but at a later stage of our check and balances. Failure in this stage of checks causes the entire system update to be skipped.

The data integration has been disabled, and will be updated to check for and handle the situation in the future.
Posted Feb 28, 2022 - 17:47 UTC
Investigating
We are investigating an issue causing utility data to not update site wide.
Posted Feb 28, 2022 - 17:39 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).