Storm Mode Activated - 2020/06/10 storm event
Incident Report for PowerOutage.us
Resolved
We have exited Storm Mode, no major issues were found during this event.
Posted Jun 11, 2020 - 18:48 UTC
Monitoring
A large storm system moving through the Great Lakes region is causing a high amount of power outages we have activated Storm Mode. We are actively monitoring our data sources, integrations, and internal systems.
Posted Jun 11, 2020 - 01:26 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).