Maps not loading on PowerOutage.us / PowerOutage.com
Incident Report for PowerOutage.us
Resolved
Azure has confirmed the issue and they are investigating on their end.

We have seen limited impact to map load times from our work around so will mark this as resolved.
You can check our discord for more follow ups: discord.gg/PRrqwe7dpD
Posted Jul 22, 2022 - 03:38 UTC
Monitoring
We have updated the site to not use the Azure CDN for now to load the map geometry, and maps are again loading. Load times for the maps may be longer than usual.

We are investigating the underlining issue with Azure CDN.
Posted Jul 21, 2022 - 15:14 UTC
Identified
Maps are not loading on PowerOoutage.us / PowerOutage.com
All underlining data is still flowing, APIs, Reporting, and Alerts are functioning fine.

The issue apears to be an expired CERT within the Azure CDN we are using to load the map geometry data.
An Emergency Deployment in progress to temporally stop using azure CDN for loading map geometry
Posted Jul 21, 2022 - 15:00 UTC
This incident affected: Power Outage Systems (Power Outage Site).