Incorrect data listed for Alabama Power
Incident Report for PowerOutage.us
Postmortem

Alabama Power started reporting inaccurate data around 4:21 PM EDT.

Alerts about the issue were placed on PowerOutage.us around 4:35 PM EDT.

We stopped importing their data around 4:55 PM EDT.

The Utility was contacted and they fixed their systems around 7:00PM EDT allowing us to get correct data again.

We began importing their corrected data around 7:30 PM EDT.

Posted May 20, 2020 - 21:44 UTC

Resolved
Alabama Power started reporting inaccurate data around 4:21 PM EDT
Posted May 17, 2020 - 08:30 UTC