Cloud flare DNS outage
Incident Report for PowerOutage.us
Resolved
Cloudflare has mitigated the issue: https://www.cloudflarestatus.com/incidents/hf8lpnp0yh5j

We only had 14 utility checks fail, and our system handled the errors fine (no data was lost only delayed for those few utilities.)
Posted Feb 19, 2021 - 03:58 UTC
Investigating
Cloud flare appears to be having a DNS outage. A few utility checks are failing, we are working on assessing impact now.
Posted Feb 19, 2021 - 03:37 UTC