Delayed sitewide updates due to downstream utility systems affected by AWS outage.
Incident Report for PowerOutage.us
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 07:26 UTC
Monitoring
We are experiencing delayed sitewide updates due to downstream utility systems affected by a AWS outage.
While we are still getting updated data, responses form some utilities' AWS A3 data buckets are very slow.

We are monitoring the situation, and will start disabling and freezing integrations if the situation escalates.
Posted Dec 07, 2021 - 17:13 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).