PowerOutage.us is not updateing
Incident Report for PowerOutage.us
Resolved
The global routing issue appears to be resolved. All our utility integrations are back up and running.

If CenturyLink/Level3 post a postmortem we will add it to this incident.
Posted Aug 30, 2020 - 15:15 UTC
Monitoring
The global routing issue appears to be resolved. We are working to bring back online the disabled utility integrations.
Posted Aug 30, 2020 - 15:04 UTC
Update
The global routing issues continue,
PowerOutage.us is now updating the majority of utility data about every 20 minutes.

We are looking for further mitigations, but this will be about as good as we can do while global routing issues persist.
Posted Aug 30, 2020 - 13:07 UTC
Update
The global routing issues continue, we have disabled a number of our utility integrations and are now intermittently updating some utility data. We continue to implement mitigations...
Posted Aug 30, 2020 - 11:44 UTC
Identified
There appears to be a large routing issue ongoing across the World Wide Web. We are working on implementing a work around to get some of our utility integrations back online.

The site and API remain up and functioning, just with stale data.
Posted Aug 30, 2020 - 11:21 UTC
Investigating
PowerOutage.us is currently not updating, we are investigating.
Posted Aug 30, 2020 - 10:52 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).