Storm Mode Activated - 2020/06/03 thunderstorm event
Incident Report for PowerOutage.us
Resolved
We have exited storm mode. No known issues arose during this event.
Posted Jun 04, 2020 - 07:31 UTC
Monitoring
A severe thunderstorm is causing major Power Outages for electric customer in Pennsylvania and New Jersey. We have activated our NOC and entered Storm Mode. We are actively monitoring all utility imports from these areas.
Posted Jun 03, 2020 - 17:45 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).