PowerOutage.us Update Delay
Incident Report for PowerOutage.us
Resolved
Utilities systems have stabilized as this outage scales down, we are back to constantly refreshing data every 10 minutes.
Posted Oct 30, 2020 - 03:55 UTC
Monitoring
Due to widespread ongoing major events effecting a huge amount of utilities, PowerOutage.us is updating about every 20 minutes instead of the usual 10 minutes.

We do have some planned upgrades in the future to help with situations like this but for now this delay will probably be in place for the remainder of this event.
Posted Oct 29, 2020 - 15:24 UTC
This incident affected: Power Outage Systems (Power Outage Site, Power Outage API).